package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([ \t]*)(@\w+(\.\w+)*)([ \t]*)`)
var str = `@annotation
@annotation value
@annotation.long.namespace
@annotation.long.namespace value
@annotation.long.namespace
@annotation.long.namespace value`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}