$re = '/^([ \t]*)(@\w+(\.\w+)*)([ \t]*)/m';
$str = '@annotation
@annotation value
@annotation.long.namespace
@annotation.long.namespace value
@annotation.long.namespace
@annotation.long.namespace value';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);