using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[?(var1|var2|x|y|z)(,(var1|var2|x|y|z))*]?=";
string input = @"var1=...
[var1,x]=...
[var2,x]=...
[x,y,var1,z]=...
[x,vvvar1,y]=..";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}