$re = '/^\[?(var1|var2|x|y|z)(,(var1|var2|x|y|z))*]?=/m';
$str = 'var1=...
[var1,x]=...
[var2,x]=...
[x,y,var1,z]=...
[x,vvvar1,y]=..';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);