const regex = /^\[?(var1|var2|x|y|z)(,(var1|var2|x|y|z))*]?=/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\[?(var1|var2|x|y|z)(,(var1|var2|x|y|z))*]?=', 'gm')
const str = `var1=...
[var1,x]=...
[var2,x]=...
[x,y,var1,z]=...
[x,vvvar1,y]=..`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}