using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^,\s]+=";
string input = @"foo=bar,pine=apple,tree,bar=bie
foo=bar,pine=apple,tree
pine=apple,tree";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}