package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^,\s]+=`)
var str = `foo=bar,pine=apple,tree,bar=bie
foo=bar,pine=apple,tree
pine=apple,tree`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}