re = /[^,\s]+=/
str = 'foo=bar,pine=apple,tree,bar=bie
foo=bar,pine=apple,tree
pine=apple,tree'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end