import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:spotify:|https:\\/\\/[a-z]+\\.spotify\\.com\\/(track\\/|user\\/(.*)\\/playlist\\/))(.*)$";
final String string = "https://play.spotify.com/user/spotifydiscover/playlist/0vL3R9wDeAwmXTTuRATa14\n"
+ "https://open.spotify.com/track/1TZ3z6TBztuY0TLUlJZ8R7\n"
+ "spotify:track:1TZ3z6TBztuY0TLUlJZ8R7";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}