$re = '/^(?:spotify:|https:\/\/[a-z]+\.spotify\.com\/(track\/|user\/(.*)\/playlist\/))(.*)$/m';
$str = 'https://play.spotify.com/user/spotifydiscover/playlist/0vL3R9wDeAwmXTTuRATa14
https://open.spotify.com/track/1TZ3z6TBztuY0TLUlJZ8R7
spotify:track:1TZ3z6TBztuY0TLUlJZ8R7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);