import re
regex = re.compile(r"^(?:spotify:|https:\/\/[a-z]+\.spotify\.com\/(track\/|user\/(.*)\/playlist\/))(.*)$", flags=re.MULTILINE)
test_str = ("https://play.spotify.com/user/spotifydiscover/playlist/0vL3R9wDeAwmXTTuRATa14\n"
"https://open.spotify.com/track/1TZ3z6TBztuY0TLUlJZ8R7\n"
"spotify:track:1TZ3z6TBztuY0TLUlJZ8R7")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")