package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Air.*\s(\-?\d+\.?\d?)C`)
var str = `24 Jul 2013: Water - 74.0F / 23.3C; Air - 68.0F / 20.0C. John L. helped out a wounded cyclist; Anthony C. swam 1km`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}