re = /Air.*\s(\-?\d+\.?\d?)C/m
str = '24 Jul 2013: Water - 74.0F / 23.3C; Air - 68.0F / 20.0C. John L. helped out a wounded cyclist; Anthony C. swam 1km'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end