#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:^Today)\D*(\d+)(?:.*\R){2}(?s)(.*?(?=stop))(?s-)"
Local $sString = "Today's XXXX ZZZZZZZ 123456" & @CRLF & _
"" & @CRLF & _
"Some paragraph of Txt......????" & @CRLF & _
"and her some other lines" & @CRLF & _
"as here" & @CRLF & _
"but stop it here" & @CRLF & _
"" & @CRLF & _
"here's another stop word which does not get recognized due to the lazy quantifier"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")