# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:^Today)\D*(\d+)(?:.*\R){2}(?s)(.*?(?=stop))(?s-)"
test_str = ("Today's XXXX ZZZZZZZ 123456\n\n"
"Some paragraph of Txt......????\n"
"and her some other lines\n"
"as here\n"
"but stop it here\n\n"
"here's another stop word which does not get recognized due to the lazy quantifier")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.