import Foundation
let pattern = #"(?:^Today)\D*(\d+)(?:.*\R){2}(?s)(.*?(?=stop))(?s-)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Today's XXXX ZZZZZZZ 123456
Some paragraph of Txt......????
and her some other lines
as here
but stop it here
here's another stop word which does not get recognized due to the lazy quantifier
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}