const regex = new RegExp('[\\w.-]+ ?(?:@|\\[?at]?) ?[\\w.-]+(?: ?\\[?dot]? ?[\\w.-]+)?', 'g')
const str = `info@example.com
info [at] example [dot] com
info at example.com info
info at example dot com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}