use strict;
my $str = 'the quick brown fox jumped over the lazy dog
the quick brown fox jumped over the lazy dog
the quick brown fox jumped over the lazy dog
the quick brown fox jumped over the lazy dog
';
my $regex = qr/(?<=^.{4,4})./mp;
my $subst = 'h';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";