re = /(?<=^.{4,4})./m
str = 'the quick brown fox jumped over the lazy dog
the quick brown fox jumped over the lazy dog
the quick brown fox jumped over the lazy dog
the quick brown fox jumped over the lazy dog
'
subst = 'h'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result