#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\(((pro\b)(( +[^)])([^ )]*))?(( +[^)])([^ )]*))?(( +[^)])([^ )]*))?(( +[^)])([^ )]*))?(( +[^)])([^ )]*))?(( +[^)])([^ )]*))? *|(.*?))\)"
Local $sString = "4377631753733131 (pro alber con tr33)" & @CRLF & _
"886uhghsdfdsfh (pro cios tui tr32)" & @CRLF & _
"rtyqrey 6y46457 6372576 (Flrt ghnap tsr)" & @CRLF & _
"537657QQRFytyvg (flipzz Reyhdf frfg33)" & @CRLF & _
"" & @CRLF & _
"4377631753733131 (pro alber con tr33 alber con tr33) (flipzz Reyhdf frfg33) (Foo pro bar pro cios tui tr32)" & @CRLF & _
"537657QQRFytyvg (pro foo ))" & @CRLF & _
"" & @CRLF & _
"I would like all words after "pro" to be capitalized. If "pro" is not present, all words in the brackets must be lowercase, for have :" & @CRLF & _
"" & @CRLF & _
"4377631753733131 (pro Alber Con Tr33)" & @CRLF & _
"886uhghsdfdsfh (pro Cios Tui Tr32)" & @CRLF & _
"rtyqrey 6y46457 6372576 (flrt ghnap tsr)" & @CRLF & _
"537657QQRFytyvg (flipzz reyhdf frfg33)"
Local $sSubst = "(${2}\U${4}\L${5}\U${7}\L${8}\U${10}\L${11}\U${13}\L${14}\U${16}\L${17}\U${19}\L${20}\L${21})"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)