import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(((pro\\b)(( +[^)])([^ )]*))?(( +[^)])([^ )]*))?(( +[^)])([^ )]*))?(( +[^)])([^ )]*))?(( +[^)])([^ )]*))?(( +[^)])([^ )]*))? *|(.*?))\\)";
final String string = "4377631753733131 (pro alber con tr33)\n"
+ "886uhghsdfdsfh (pro cios tui tr32)\n"
+ "rtyqrey 6y46457 6372576 (Flrt ghnap tsr)\n"
+ "537657QQRFytyvg (flipzz Reyhdf frfg33)\n\n"
+ "4377631753733131 (pro alber con tr33 alber con tr33) (flipzz Reyhdf frfg33) (Foo pro bar pro cios tui tr32)\n"
+ "537657QQRFytyvg (pro foo ))\n\n"
+ "I would like all words after \"pro\" to be capitalized. If \"pro\" is not present, all words in the brackets must be lowercase, for have :\n\n"
+ "4377631753733131 (pro Alber Con Tr33)\n"
+ "886uhghsdfdsfh (pro Cios Tui Tr32)\n"
+ "rtyqrey 6y46457 6372576 (flrt ghnap tsr)\n"
+ "537657QQRFytyvg (flipzz reyhdf frfg33)";
final String subst = "(${2}\\U${4}\\L${5}\\U${7}\\L${8}\\U${10}\\L${11}\\U${13}\\L${14}\\U${16}\\L${17}\\U${19}\\L${20}\\L${21})";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}