# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?=.*?(\w+)\W*(\w+)\W+([JS]r)$).*/$3,$1,$2,$3./gm;t' <<< ".xy z., Jr
Jr, .xy z., Jr
Jr. xy z., Sr
,Jr xy, z, Jr
.Jr .xy, z., Jr
Sr\ .xy z., Jr
Ser, xy , z., Jr
./Sr xy,/ z., Jr
<<sr, xy z, Jr
SR, .xy z., Jr
[]sa, .xy z., Jr
ps xy z., Jr
asa xy z., Jr
asad .xy z., Jr
bs/ .xy z., Jr
p[], .xy z., Jr
lold.,.xy z., Jr
scs., .xy z., Jr
losdj .xy z., Jr
.xy z., Jr
.xy./z., Jr
sa .xy z., Jr"