use strict;
my $str = '.xy z., Jr
Jr, .xy z., Jr
Jr. xy z., Sr
,Jr xy, z, Jr
.Jr .xy, z., Jr
Sr\\ .xy z., Jr
Ser, xy , z., Jr
./Sr xy,/ z., Jr
<<sr, xy z, Jr
SR, .xy z., Jr
[]sa, .xy z., Jr
ps xy z., Jr
asa xy z., Jr
asad .xy z., Jr
bs/ .xy z., Jr
p[], .xy z., Jr
lold.,.xy z., Jr
scs., .xy z., Jr
losdj .xy z., Jr
.xy z., Jr
.xy./z., Jr
sa .xy z., Jr';
my $regex = qr/^(?=.*?(\w+)\W*(\w+)\W+([JS]r)$).*/mp;
my $subst = '$3,$1,$2,$3.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";