const regex = /^(?=.*?(\w+)\W*(\w+)\W+([JS]r)$).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*?(\\w+)\\W*(\\w+)\\W+([JS]r)$).*', 'gm')
const str = `.xy z., Jr
Jr, .xy z., Jr
Jr. xy z., Sr
,Jr xy, z, Jr
.Jr .xy, z., Jr
Sr\\ .xy z., Jr
Ser, xy , z., Jr
./Sr xy,/ z., Jr
<<sr, xy z, Jr
SR, .xy z., Jr
[]sa, .xy z., Jr
ps xy z., Jr
asa xy z., Jr
asad .xy z., Jr
bs/ .xy z., Jr
p[], .xy z., Jr
lold.,.xy z., Jr
scs., .xy z., Jr
losdj .xy z., Jr
.xy z., Jr
.xy./z., Jr
sa .xy z., Jr`;
const subst = `$3,$1,$2,$3.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);