#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b[A-Z].*?(?= [a-z])"
Local $sString = "wikiradio 27/09/2012 - LE QUATTRO GIORNATE DI NAPOLI raccontate da Ida Gribaudi" & @CRLF & _
"" & @CRLF & _
"wikiradio 10/04/2013 - DAG HAMMARSKJOLD raccontato da Susanna Pesenti" & @CRLF & _
"" & @CRLF & _
"wikiradio 11/02/2014 - L'ABBE' PIERRE raccontato da Giovanni Anversa" & @CRLF & _
"" & @CRLF & _
"wikiradio 22/12/2015 - JEAN-MICHEL BASQUIAT raccontato da Costantino D'Orazio"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")