const regex = /\b[A-Z].*?(?= [a-z])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[A-Z].*?(?= [a-z])', 'g')
const str = `wikiradio 27/09/2012 - LE QUATTRO GIORNATE DI NAPOLI raccontate da Ida Gribaudi
wikiradio 10/04/2013 - DAG HAMMARSKJOLD raccontato da Susanna Pesenti
wikiradio 11/02/2014 - L'ABBE' PIERRE raccontato da Giovanni Anversa
wikiradio 22/12/2015 - JEAN-MICHEL BASQUIAT raccontato da Costantino D'Orazio`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}