re = /\b[A-Z].*?(?= [a-z])/
str = 'wikiradio 27/09/2012 - LE QUATTRO GIORNATE DI NAPOLI raccontate da Ida Gribaudi
wikiradio 10/04/2013 - DAG HAMMARSKJOLD raccontato da Susanna Pesenti
wikiradio 11/02/2014 - L\'ABBE\' PIERRE raccontato da Giovanni Anversa
wikiradio 22/12/2015 - JEAN-MICHEL BASQUIAT raccontato da Costantino D\'Orazio'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end