using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Betrag:)(([\s]*)\d{1,8}([\.,]\d{2})){2}";
string input = @"Betrag: 100,00 150,00 350,00";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}