const regex = /(?<=Betrag:)(([\s]*)\d{1,8}([\.,]\d{2})){2}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Betrag:)(([\\s]*)\\d{1,8}([\\.,]\\d{2})){2}', '')
const str = `Betrag: 100,00 150,00 350,00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}