import re
regex = re.compile(r"(?<=/os/).*(?=[?])", flags=re.MULTILINE)
test_str = "/maximo/oslc/os/mxapiwodetail?lean=1&oslc.select=*&savedQuery=cxmobile_4abc"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")