re = /(?<=\/os\/).*(?=[?])/m
str = '/maximo/oslc/os/mxapiwodetail?lean=1&oslc.select=*&savedQuery=cxmobile_4abc'
# Print the match result
str.match(re) do |match|
puts match.to_s
end