const regex = new RegExp('(\\d+)d (\\d+)h (\\d+)(?:min|m) (\\d+)s', '')
const str = `5d 23h 40min 56s`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}