package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:&[^ ]+?;)|;(\w+)`)
var str = `this >word1 is a special ;word2 with ;word3 &lol;qqqq&gaa;qqq;lll`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}