$re = '/(?:&[^ ]+?;)|;(\w+)/';
$str = 'this >word1 is a special ;word2 with ;word3 &lol;qqqq&gaa;qqq;lll';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);