// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:&[^ ]+?;)|;(\w+)").unwrap();
let string = "this >word1 is a special ;word2 with ;word3 &lol;qqqq&gaa;qqq;lll";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}