const regex = /<(?>!\[CDATA\[(?>\[[^]]*+])*+([^\[\]>]++)(?>\[[^]]*+])*+[^]]*+]]>|[^>]*+>(*SKIP)(*FAIL))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(?>!\\[CDATA\\[(?>\\[[^]]*+])*+([^\\[\\]>]++)(?>\\[[^]]*+])*+[^]]*+]]>|[^>]*+>(*SKIP)(*FAIL))', 'gm')
const str = `<bsndbadas> dhsjahdjskah <![CDATA[[vc_row][vc_column][vc_column_text] lda d a jdksajkld akl dsak jda jda sdjsa dklsa jdkajklda ada skkas [/vs_volumn_text][/vs_column][/vc_row] ]]> asdhakhj</bsdhsjahdsa>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}