$re = '/<(?>!\[CDATA\[(?>\[[^]]*+])*+([^\[\]>]++)(?>\[[^]]*+])*+[^]]*+]]>|[^>]*+>(*SKIP)(*FAIL))/m';
$str = '<bsndbadas> dhsjahdjskah <![CDATA[[vc_row][vc_column][vc_column_text] lda d a jdksajkld akl dsak jda jda sdjsa dklsa jdkajklda ada skkas [/vs_volumn_text][/vs_column][/vc_row] ]]> asdhakhj</bsdhsjahdsa>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);