import Foundation
let pattern = #"<(?>!\[CDATA\[(?>\[[^]]*+])*+([^\[\]>]++)(?>\[[^]]*+])*+[^]]*+]]>|[^>]*+>(*SKIP)(*FAIL))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<bsndbadas> dhsjahdjskah <![CDATA[[vc_row][vc_column][vc_column_text] lda d a jdksajkld akl dsak jda jda sdjsa dklsa jdkajklda ada skkas [/vs_volumn_text][/vs_column][/vc_row] ]]> asdhakhj</bsdhsjahdsa>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)