package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*?\/[0-9]\.[0-9]\+\((.*?)\;.*`)
var str = `Mozilla/5.0+(iPad;+CPU+OS+8_3+like+Mac+OS+X)+AppleWebKit/600.1.4+(KHTML,+like+Gecko)+Version/8.0+Mobile/12F69+Safari/600.1.4`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}