re = /.*?\/[0-9]\.[0-9]\+\((.*?)\;.*/
str = 'Mozilla/5.0+(iPad;+CPU+OS+8_3+like+Mac+OS+X)+AppleWebKit/600.1.4+(KHTML,+like+Gecko)+Version/8.0+Mobile/12F69+Safari/600.1.4'
# Print the match result
str.match(re) do |match|
puts match.to_s
end