$re = '/<a href="(\/string1\/)(.*?)(\/string2)">/';
$str = '<a href="/string1/any string here/string2">text here</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);