re = /<a href="(\/string1\/)(.*?)(\/string2)">/
str = '<a href="/string1/any string here/string2">text here</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end