#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?=.*[A-Z]+)([a-zA-Z]+)\b"
Local $sString = "Just some random text" & @CRLF & _
"to Test a RegEx" & @CRLF & _
"that should extract" & @CRLF & _
"Words and WordS" & @CRLF & _
"but not words and WORDS"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")