$re = '/\b(?=.*[A-Z]+)([a-zA-Z]+)\b/m';
$str = 'Just some random text
to Test a RegEx
that should extract
Words and WordS
but not words and WORDS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);