using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?=.*[A-Z]+)([a-zA-Z]+)\b";
string input = @"Just some random text
to Test a RegEx
that should extract
Words and WordS
but not words and WORDS";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}