const regex = /https:\/\/example\.com\/folder1\/folder2\/([^\/]*).*[^\/]*\//;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/example\\.com\\\/folder1\\\/folder2\\\/([^\\\/]*).*[^\\\/]*\\\/', '')
const str = `https://example.com/folder1/folder2/folder3/folder4/page.html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}