$re = '/https:\/\/example\.com\/folder1\/folder2\/([^\/]*).*[^\/]*\//';
$str = 'https://example.com/folder1/folder2/folder3/folder4/page.html';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);