re = /https:\/\/example\.com\/folder1\/folder2\/([^\/]*).*[^\/]*\//
str = 'https://example.com/folder1/folder2/folder3/folder4/page.html'
# Print the match result
str.match(re) do |match|
puts match.to_s
end