#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=\s|\.)(\s|.)(multi|dual|ita-eng)(?=\s|\.)(\s|.)"
Local $sString = "ds.multi." & @CRLF & _
"dsd dual" & @CRLF & _
"ds.ita-eng." & @CRLF & _
"this is multiplayer " & @CRLF & _
"dualipa" & @CRLF & _
" dual " & @CRLF & _
".dual." & @CRLF & _
" dual." & @CRLF & _
" italian and english" & @CRLF & _
"this is aramulti "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")