import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\s|\\.)(\\s|.)(multi|dual|ita-eng)(?=\\s|\\.)(\\s|.)";
final String string = "ds.multi.\n"
+ "dsd dual\n"
+ "ds.ita-eng.\n"
+ "this is multiplayer \n"
+ "dualipa\n"
+ " dual \n"
+ ".dual.\n"
+ " dual.\n"
+ " italian and english\n"
+ "this is aramulti ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}